Re: [pyar] Instalando PIL con pip (Requirements Files)

Página superior
Adjuntos:
+ (text/plain)
Eliminar este mensaje
Responder a este mensaje
Autor: Ernesto Savoretti
Fecha:  
A: Python Argentina
Asunto: Re: [pyar] Instalando PIL con pip (Requirements Files)
El día 22 de octubre de 2010 18:53, Maximiliano Robaina
<> escribió:
> Hola,
>
> Estoy tratando de armar un entorno desde cero (virtualenv) usando pip.
> Para esto tengo un archivo de requerimientos [1] de pip en el cual tengo
> especificado las versiones de cada paquete a instalar.
> Dicho archivo tiene lo siguiente:
>
> Django==1.2.1
> PIL==1.1.7
> kinterbasdb==3.3.0
> reportlab==2.5
> html5lib==0.11.1
> pyPdf==1.12
> pisa==3.0.33
>
> El problema acá es cuando quiere instalar PIL. O interprete mal lo que
> debe hacer o no hace lo que yo quiero. El tema es que cuando intenta
> instalar PIL me dice que ya existe y en realidad tiene razón, porque
> está en /usr/lib/python2.6/dist-packages/PIL
> El mensaje concreto es:
>
> Requirement already satisfied (use --upgrade to upgrade): PIL==1.1.7
> in /usr/lib/python2.6/dist-packages/PIL (from -r stable-req.txt (line
> 2))
>
> Ahora, como hago para forzar a que pip me lo instale dentro de mi
> virtualenv?
>


Podemos asumir que usaste source bin\activate en el directorio
correspondiente antes de usar pip install?
O preguntado de otra manera: te aparece al principio de tu prompt el
virtualenv activo entre paréntesis?
Por último, creaste tu virtualenv con la opción --no-site-packages?

--

                                    Ernesto Savoretti
_______________________________________________
pyar mailing list
http://listas.python.org.ar/listinfo/pyar

PyAr - Python Argentina - Sitio web: http://www.python.org.ar/